TACTIC Open Source
Service install in RHEL - Printable Version

+- TACTIC Open Source (http://forum.southpawtech.com)
+-- Forum: TACTIC Open Source (http://forum.southpawtech.com/forumdisplay.php?fid=3)
+--- Forum: TACTIC Discussion (http://forum.southpawtech.com/forumdisplay.php?fid=4)
+--- Thread: Service install in RHEL (/showthread.php?tid=40)

Pages: 1 2

Service install in RHEL - dankitchen - 12-05-2019

Hey Guys :-)  I have installed TACTIC on a RHEL aws instance but, i am having trouble figuring out how to install the service.  I know in the past you would move the service file under the install dir to /etc/init.d but it seems it is a bit of a different case with this distro.   I have included the OS info below

4.18.0-80.4.2.el8_0.x86_64 #1 SMP Fri Jun 14 13:20:24 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


RE: Service install in RHEL - lwinmoe - 12-05-2019

It is possible that RHEL 8 no longer supports backwards compatibility with init.d. As far as I know, in CentOS 7 and RHEL 7, the init service commands are redirected to systemctl.

RE: Service install in RHEL - remkonoteboom - 12-05-2019

Hey there!

RHEL 8 came out about six months ago and they have deprecated the old init.d in favor of systemctl.  We have been relying the auto-mapping functionality of systemctl to handle the init.d script.  Howerver, it seems that these days may be over. I am not sure how to install the init.d functionality onto RHEL 8.

We may need to have add in a proper systemctl script.

RE: Service install in RHEL - dankitchen - 12-05-2019

Hey Remko, thanks! I will have a quick look and see if there is some sort of way to get it to work. Otherwise, I will spin up a different AWS instance and install again. which distro would be the most recommended to use on AWS?

RE: Service install in RHEL - remkonoteboom - 12-05-2019

Just found out: you may just have to install chkconfig rpm to make it work:

dnf install chkconfig

What distro you use really depends on your preference and what you are using it for. For development, we use Fedora 30/31 because it has all the bells and whistles and it's dead easy to install. It's not a bad option if you don't mind frequent updates to the OS. You can get a link to the AWS image from here:


For more stable (read: it doesn't change much over time), we have deployed CentOS and RHEL on customer sites.

RE: Service install in RHEL - dankitchen - 12-05-2019

So I took a look in the /etc/init.d folder and there is a README (funny thing) ...content below. This seems to somewhat work. it does attempt to start (I get the correct output) but the actucal tactic processes are not started. I am able to run startup_dev.py or startup.py fine and tacitc start and runs. Is there somewhere I can look to check for error output from the attempt to start the service? I checked /tactic_temp/log/ files but nothing coming up there. One note as well is that I am trying the tactic_python3 service file assuming that I need it based on this install using python3


Here's an explanation on what's going on:

You are running a systemd-based OS where traditional init scripts have
been replaced by native systemd services files. Service files provide
very similar functionality to init scripts. To make use of service
files simply invoke "systemctl", which will output a list of all
currently running services (and other units). Use "systemctl
list-unit-files" to get a listing of all known unit files, including
stopped, disabled and masked ones. Use "systemctl start
foobar.service" and "systemctl stop foobar.service" to start or stop a
service, respectively. For further details, please refer to

Note that traditional init scripts continue to function on a systemd
system. An init script /etc/rc.d/init.d/foobar is implicitly mapped
into a service unit foobar.service during system initialization.

RE: Service install in RHEL - lwinmoe - 12-06-2019

Did you also check /var/log/tactic? Does it say anything there?

RE: Service install in RHEL - dankitchen - 12-06-2019

(12-06-2019, 03:54 PM)lwinmoe Wrote: Did you also check /var/log/tactic? Does it say anything there?

I don't appear to have that log folder in this install.

RE: Service install in RHEL - dankitchen - 12-09-2019

So I decided to try an install on FC30 (5.0.9-301.fc30.x86_64 #1 SMP Tue Apr 23 23:57:35 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux) and everything seems fine but I am having some issues getting the service to install in this instance as well. Is there specific docs on getting it going where I assume I have to use the tactic_python3 service file?

I tried copying the tactic_python3 service file to /etc/init.d/ then running chmod 755 on the file, then chkconfig tactic on and chkconfig --levels 2345 tactic but it still doesn't appear to start.

I am sure I am missing something simple :-)

RE: Service install in RHEL - remkonoteboom - 12-09-2019

If you try running tactic_python3 directly from the command line:

# tactic_python3 start

Does it give any errors?