TACTIC Open Source
Freeze at Loading Project - Printable Version

+- TACTIC Open Source (http://forum.southpawtech.com)
+-- Forum: TACTIC Open Source (http://forum.southpawtech.com/forumdisplay.php?fid=3)
+--- Forum: TACTIC Discussion (http://forum.southpawtech.com/forumdisplay.php?fid=4)
+--- Thread: Freeze at Loading Project (/showthread.php?tid=235)

Pages: 1 2

Freeze at Loading Project - Nachogor - 07-28-2021

Hi guys,

Something desperating is happening again: I login as admin, and I get stucked in the Loading "Project Name"
If I start in debug mode I only get this:

[root@localhost ~]# su - tactic -c '/usr/bin/python3 /opt/tactic/tactic/src/bin/startup_dev.py -p 7000 -s'

Data Directory [/opt/tactic/tactic_data]
Asset Directory [/opt/tactic/assets]
Temp Directory [/spt/tactic/tactic_temp]
Config path [/opt/tactic/tactic_data/config/tactic-conf.xml]
Registering project ... admin
Registering project ... proyect_test_template_8
Registering project ... ramon_master_ver_
Registering project ... template_correcciones
Registering project ... template_v8_test
Registering project ... vfx_test
Registering project ... vfx_test_2
Registering project ... default
Initializing Workflow Engine
Starting Scheduler ....

Starting TACTIC v4.8.0 ...

ticket:  c08ca1424d0ef75982c

Github up to date.

No error messages in exception Log table, or in apache logs.

Is there any way to set a verbose version of startup_dev.py? Any ideas? Tried opening from within the VMWare Fedora machine and from 2 windows PCs in the same network and the result is always the same.


RE: Freeze at Loading Project - remkonoteboom - 07-28-2021

What does the regular "python startup.py" from the command line print out. I have seen on occasion that the non-debug mode prints out a stack trace that the startup_dev.py does not (this doesn't make sense, but I haven't had a chance to debug this yet).

Also, is this the root url?

RE: Freeze at Loading Project - Nachogor - 07-28-2021

Thanks Remko!
This never happened to me in 4.5 but it´s freezing me completly. I also tried connecting with our API and it works.

Sorry it took so long to answer but we found out that there are a couple of JS exceptions (Client side)

First one regarding SHA-256 integrity (image attached) maybe I have an corrupt library in my install? I could download it and see if that fixes the error

Second one in Object.spt.behavior.run_cbjs regarding bmdRipples (also image attached)

Let me know if you need any more information.

Thanks again!

RE: Freeze at Loading Project - remkonoteboom - 07-28-2021

Could this be an http / https issue? From the second image you have, it looks like it is trying to access a resource using http and it is being blocked. These are the lines that that load in this popper file and bootstrap file.

<script src="/context/spt_js/jquery/jquery-3.4.1.min.js"></script>
<script src="/context/spt_js/jquery/jquery-ui.min.js"></script>
<script src="/context/spt_js/jquery/popper.min.js" integrity="sha384-UO2eT0CpHqdSJQ6hJty5KVphtPhzWj9WO1clHTMGa3JDZwrnQq4sF86dIHNDz0W1" crossorigin="anonymous"></script>

<script src="/context/spt_js/bootstrap_material_design/bootstrap-material-design-4.1.1.js" integrity="sha384-CauSuKpEqAFajSpkdjv3z9t8E7RlpJ1UP0lKM/+NdtSarroVKu069AlsRPKkFBz9" crossorigin="anonymous"></script>

These lines may be the problem.

These are set in <TACTIC_INSTALL>/src/tactic/ui/top_wdg.py

RE: Freeze at Loading Project - Nachogor - 07-28-2021

Deleted TACTIC/src and replaced it again with the last one from Github and it works again.

What I still don't understand is why every now and then I get this error again. Would help me a lot if you can confirm wether this is related to the error regarding bootstrap and material design js or the other error regarding the loading and initialization of templates (at least that's what I understood it was)


RE: Freeze at Loading Project - remkonoteboom - 07-28-2021

The errors you showed me has something to do with the browser not able to load the js files. This has nothing to do with the templates/plugins discussion.

If you notice the errors are referring to the "integrity" attribute in the script tag:


My guess is that this is some kind of a checksum and when you did a git checkout, it changed these files (different newlines, for example) in such a way that it no longer passed an integrity test. I had copied these attributes from their corresponding websites. I don't think they are necessary because we are using local versions and not downloading over the web.

RE: Freeze at Loading Project - Nachogor - 07-28-2021

Thanks! If it happens again I`ll try to send you more information.

RE: Freeze at Loading Project - remkonoteboom - 07-28-2021

I am pretty sure that when you clone/checked out Git, it changed the newlines and this caused the integrity check to fail. Whatever you did the last time didn't change the file and now it is working. I don't think we need to have the integrity check as I mentioned above and will remove soon.

RE: Freeze at Loading Project - LazyLeopard - 07-29-2021

Thankyou! this thread has helped me remove the problem I faced while deploying tactic 4.8 on windows, since windows requires full CRLF characters and git has a setting which replaces newlines depending on the host OS.

A quick grep has found me:

3 occurrences of the SRI check for local resources in <install_dir>/src/tactic/ui/app/top_wdg.py
1 occurrence of the SRI check for a local resource in <install_dir>/src/pyasm/widget/error_wdg.py

these are probably unnecessary for local resources and hence should be removed.

RE: Freeze at Loading Project - Nachogor - 07-29-2021

In my case I think is depends on the way I copy the github updates:

Mounted Windows Drive in Fedora and copy
Drag and drop files
Mounted Windows Drive in Fedora and copy a zip and then uncompress

I think only the last one works ok. Vmware player 15.