TACTIC Open Source
REWARD$$$$$ - Printable Version

+- TACTIC Open Source (http://forum.southpawtech.com)
+-- Forum: TACTIC Open Source (http://forum.southpawtech.com/forumdisplay.php?fid=3)
+--- Forum: TACTIC Discussion (http://forum.southpawtech.com/forumdisplay.php?fid=4)
+--- Thread: REWARD$$$$$ (/showthread.php?tid=131)

REWARD$$$$$ - Dag - 06-03-2020


I give up to try do things I do not understand and want to pay for a configuration of a full running system.

What I want to have:

- VirtualBox OVA or VDI - I can send a preconfigured Fedora32 OVA or VDI
- assets should be stored on a network share
- full Integration of Tactic-Handler (I will ask Listique Alexey for permission)
- setting of all services and permissions in system (Fedora 32 - Cinnamon Desktop)
- The full IP, user, etc. comes on a request sheet, so you know exactly how I want to have it to work.
- please send me a PM with a price and how long it would took

RE: REWARD$$$$$ - listy - 06-03-2020

Have you tried to install tactic server to your NAS?
What is the specs of it?
We have tactic server which runs on 1.8 ghz + 1gb ram and it works pretty well.

RE: REWARD$$$$$ - Dag - 06-03-2020


Intel Atom C2538, 2.4 GHz, 4 cores, 16GB RAM

this is maybe to weak for run on it, and the second reason is I also do not have any idea how to install TACTIC on it.
This would be the best solution for me, but... It could be also rewarded for anyone who have knowledge of this.

RE: REWARD$$$$$ - remkonoteboom - 06-03-2020

Your machine with 4 Cores and 16GB RAM should have no problem running it unless you have a lot of users or you are doing heavy processing.

For those who are interested, I have include my step by step notes on my last installation on Fedora 31.  It should be very similar on Fedora 32:

Create a TACTIC user

# su
# useradd tactic
# passwd tactic
# chmod -R 755 /home/tactic

Install Apache
# yum install httpd
# systemctl enable httpd
# systemctl start httpd

Initialize postgresql

# yum install postgresql-server
# su postgres
# initdb /var/lib/pgsql/data
# exit
# systemctl start postgresql
# systemctl enable postgresql

Install Git
# yum install git

Prepare python

# su
# yum install python3-cryptodomex
# yum install python3-lxml
# yum install python3-pillow
# yum install python3-psycopg2
# yum install python3-pytz
# yum install python3-requests

Check out TACTIC
To install in the location "/home/tactic".  You can use any folder for your installation, however, you must adjust the apache config files to reflects this.

# su tactic
# cd /home/tactic
# git clone https://github.com/Southpaw-TACTIC/TACTIC.git
# git checkout 4.8

Install TACTIC

# su
# cd /home/tactic/TACTIC/src/install
# python install.py

base_path: /home/tactic
user: tactic

# cd /home/tactic
# chown -R tactic.tactic /home/tactic
# rm tactic
# ln -s TACTIC tactic
# rm -fr tactic_src_4.6.0.a02

Prepare apache

# systemctl start httpd
# systemctl enable httpd

Disable selinux (mostly for samba)
Although this is not ideal, it does make the process of getting up and running more quickly.

# su
# vi /etc/selinux/config

# shutdown -r now

Optional for VM preparation

Prepare smb

# su
# yum install samba
# smbpasswd -a tactic

(add your password)

# vi /etc/samba/smb.conf

        comment = TACTIC Home
        path = /home/tactic
        read only = no
        guest ok = yes

# systemctl start smb
# systemctl enable smb

Prepare firewall

# su
# firewall-cmd --permanent --add-service http
# firewall-cmd --permanent --add-service https
# firewall-cmd --permanent --add-service samba
# firewall-cmd --reload

RE: REWARD$$$$$ - Dag - 06-04-2020


thank you for this step by step install doc.
It based on a allready installed TACTIC?
Because there is no copy option of the DB and HTTP configs.
Also the systemctl for service tactic.

When I run systemctl enable tactic I get this msg:

[tactic@TACTIC-SRV bin]$ sudo systemctl enable tactic
tactic.service is not a native service, redirecting to systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable tactic
Failed to execute /usr/lib/systemd/systemd-sysv-install: File or Directory not found

RE: REWARD$$$$$ - remkonoteboom - 06-04-2020

All those files should have been copied when you ran:

# python install.py

under the "TACTIC Install" section in my instructions above.

RE: REWARD$$$$$ - Dag - 06-04-2020

hmm... unfortunately it does not.

I copied it manually but to run it as service I got the msg I wrote above

RE: REWARD$$$$$ - listy - 06-04-2020

You can try to use already created VM with fedora 30.
You can update it to latest 4.8.

RE: REWARD$$$$$ - Dag - 06-04-2020

Yes, and I did it already, but I got after the update strenge behaviors. And further the problem with the broken links and rights when I want to store my data on the nas remains the same.
So I suggested, I'm not the super admin so I look for someone who want to make some money and I have a running system Smile